Moviestorm needs Java 6

On Macs, Moviestorm requires either Java 6 or Java 5 to run.

If installing Moviestorm on Yosemite, you may have Java 8 installed, but not Java 6.

This thread has a link to which should allow the use of Java 6.

Apparently the Java 8.20 which was available on Yosemite was preventing older versions of Java being used. It may be necessary to update it to 8.25 before Java 6 is usable.